SharePoint 2013 : Setup is unable to proceed due to the following error(s): This product requires Microsoft .Net Framework 4.5

I also ran into this trouble spot one day when I was installing SharePoint 2013 for a client.

Setup is unable to proceed due to the following error(s): This product requires Microsoft .Net Framework 4.5

So you need to check which version of .NET framework is installed on the server :

 Set-Location 'HKLM:\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Client'
 Get-ItemProperty -Path . | Select-Object Version

Then depending on the version installed and the OS you’re using, you need to uninstall the corresponding KB :

.NET Framework 4.6.1 : https://support.microsoft.com/en-us/kb/3102436

  1. Windows 8 ou Windows Server 2012 : KB3102439
  2. Windows 8.1 or Windows Server 2012 R2 : KB3102467
  3. Windows 10 : KB3102495

.NET Framework 4.6 : https://support.microsoft.com/fr-fr/kb/3045560

  1. Windows 8 or Windows Server 2012 : KB3045562
  2. Windows 8.1 or Windows Server 2012 R2 : KB3045563
Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s